記憶中要讓 ASP.NET 連上 Oracle ,需使用相關的 Providers 和搭配 System.Data.OracleClient,其中一個注意事項是要安裝 Oracle Client 8.1.7以上的版本。Google確認一下記憶,卻意外的發現 ADO.NET Team 已經宣告不建議使用 System.Data.OracleClient


 
主要是因為開發者大部分都使用廠商提供的 Providers ,因為 Oracle 異動的很快,ADO.NET Team 似乎無法快速反應相關新功能,只好放棄專注在其他方面,讓其他專業的來處理這一塊,所以決定將 System.Data.OracleClient .NET 4.0 時標明為 Deprecated (不建議使用)
 
找了一下 System.Data.OracleClient 替代方案:
1. ODP.NETOracle本身的解決方案,應該也是大部分一直用的方案,重點是免費的(Oracle真的是OpenSource殺手,還我OpenSolaris, OpenOffice)
,

mark528 發表在 痞客邦 PIXNET 留言(0) 人氣()